Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

With version 12 and 14 of PIPE-FLO Professional and Flow of Fluids Premium we've moved from the legacy Sentinel RMS/ Superpro key licensing to the new Sentinel LDK/ Sentinel Hasp HL key.

To continue to run older PIPE-FLO/Flow of Fluids programs once you've updated your licensing to version 12, 14 or 1415, you will need to follow the steps in this article to update your licensing.

The patch is applied to computers running the PIPE-FLO Professional 2009a/Compressible 2007/Stock 2007 and Flow of Fluids 2009a desktop clients.

Do not apply this patch unless you have version 12.x or , 14.x or 15.x licensing available, as it will make your legacy licensing unusable.

1. Download the patch from HERE (Save it to your desktop).

2. Run the patch installer with administrative privileges on your user (Client) machine.

Once the patch has been applied, you can plug in your Sentinel Hasp HL key (standalone versions).

For Enterprise versions, after the patch is applied, it should find the active Sentinel LDK server running on your network on the same subnet. 

The legacy license patch also sets up the needed folders and files so your legacy program can be configured to locate your license server (for clients on multiple subnets).

If you run PIPE-FLO/Flow of Fluids and you see the splash screen start and disappear, this means you are running the program without a license

The file (hasp_109311.ini) that needs to be edited with your license server's IP address can be found at:

  • For Windows Vista/7 8/8.1 and 10 Users:
    C:\Users\<username>\AppData\Local\SafeNet Sentinel\Sentinel LDK\
  • For XP Users:
    C:\Documents and Settings\<username>\Local Settings\Application Data\SafeNet Sentinel\Sentinel LDK\

Simply open the file with notepad and add the IP address after the SERVERADDR=    
Then save the file. 

You may reference the KB article, Specifying a servers location for additional information about the hasp_109311.ini file

Products supported by this patch:

PIPE-FLO Professional 2009a
(This is the maintenance release version of 2009) If you are not sure if you have it installed please go to http://www.eng-software.com/update/pf_1100.aspx and follow the steps.
The patch will only work on the 2009a version of Professional.

PIPE-FLO Compressible 2007

PIPE-FLO Stock 2007

Flow of Fluids 2009a
(This is the maintenance release version of 2009) If you are not sure if you have it installed please go to http://www.eng-software.com/update/ff_1100.aspx and follow the steps.
The patch will only work on the 2009a version of Flow of Fluids.